IT Services investigating issues with PrintSmart

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Feb 14, 2026 - 11:10 CST

Investigating

IT Services is investigating issues with PrintSmart's Web Print.
Posted Feb 14, 2026 - 10:24 CST
This incident affected: Computer Labs & Printing (Student Printing).