IT Services investigating Listserv issues

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 09:16 CST

Investigating

IT Services is investigating latency issues with Listserv. Message delivery may be delayed.
Posted Nov 19, 2025 - 08:22 CST
This incident affected: Collaboration Tools (Listserv).