IT Services assisting students after phishing attacks

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:42 CDT

Identified

The IT Help Desk is working with the cybersecurity team to assist students impacted by recent phishing attacks. The teams are working as quickly as possible to resolve these issues. We appreciate your patience as we work through the ticket and call queue.
Posted Oct 06, 2025 - 09:22 CDT
This incident affected: IT Systems (Other).